odoo10 安装python的依赖及坑error: command gcc failed with exit status 1

安装 odoo 微信模块
https://github.com/JoneXiong/oejia_wx/tree/9.0
提示要求安装python的依赖,有

注:v0.3及以上版本由于包含微信企业号功能请先安装依赖的python包:pycrypto(或cryptography)、xmltodict、optionaldict

主要用pip来安装

1.在windos下

进入odoo的相关目录,用pip安装,

Windows下安装pip:

快捷方法:

1、1.在windos下

找到 C:\Python27\Scripts 目录:直接运行 easy_install.exe pip  就搞定了 安装pip,然后用pip安装

D:\odoo10\runtime\python\Scripts>pip.exe install -r d:\odoo10\odoo10\source\requirements.txt -i https://mirrors.ustc.edu.cn/pypi/web/simple

其中requirements.txt里有相关模块,如

pycrypto==2.6.1
xmltodict==0.10.2
optionaldict

2.在Linux下

在Linux下执行curl https://bootstrap.pypa.io/get-pip.py | python 进行下载安装pip

这样很方便了  想装什么包就装什么包

Pip install xxx

注意:升级完python版本注意,可能你的yum命令不能使用,因为yum命令使用python写的

# vi /usr/bin/yum  #打开yum命令文件,更改第一行脚本启动地址

1.在windos下

改成上面 步骤4中的  /usr/bin/python2.7   就ok

3.装pycrypto模块

一般模块pip都ok,但装 pycrypto 会有问题,报类似错误


error: Setup script exited with error: command 'gcc' failed with exit status 1`

参考此文后解决

python - error: command 'gcc' failed with exit status 1 while installing eventlet - Stack Overflow
http://stackoverflow.com/questions/11094718/error-command-gcc-failed-with-exit-status-1-while-installing-eventlet

执行

sudo yum install python-devel
pip install pycrypto

成功。

按照odoo安装文档要求

These are available in -dev or -devel packages for Python, Postgres, libxml2, libxslt, libevent, libsasl2 and libldap2. Then the Python dependecies can themselves be installed:

故最好安装如下扩展, centos用 python27-devel, unbuntu用 python27-dev

yum -y install gcc libxml2 libxml2-devel libxslt libxslt-devel libevent libevent-devel libsasl2 libsasl2-devel libldap2 libldap2-devel

如果还不成功就源码安装

python 安装 PostgreSQL 模块:psycopg2

 

wget  http://initd.org/psycopg/tarballs/PSYCOPG-2-6/psycopg2-2.6.2.tar.gz
tar xf psycopg2-2.6.tar.gz
cd psycopg2-2.6
yum install -y postgresql-devel
python setup.py build
sudo python setup.py install

装python-ldap也会出错,这时要先装依赖

yum install -y openldap openldap-clients openldap-devel openssl-devel

再安装就成功了。

pip install python-ldap

4.安装 NPM,CNPM和LESS

因为npm经常访问不到,因此要用cnpm

yum install npm
npm install -g cnpm --registry=https://registry.npm.taobao.org
sudo cnpm install -g less less-plugin-clean-css

 

5.安装 postgresql

sudo yum install -y postgresql-server
sudo postgresql-setup initdb
sudo systemctl enable postgresql
sudo systemctl start postgresql

创建用户

sudo -u postgres createuser --createdb --no-createrole --no-superuser --pwprompt odoo

设置密码为odoo1

 

6.安装 wkhtmltopdf,用于将网页转换成pdf打印

sudo yum install -y wkhtmltopdf

7. 最后装 odoo 10

下例是装在 /opt/odoo10目录,
odoo-10.0-20161210 是解压后目录,可能会有所不同

wget  http://nightly.odoo.com/10.0/nightly/src/odoo_10.0.latest.tar.gz
tar xf odoo_10.0.latest.tar.gz 
mv odoo-10.0-20161210/* /opt/odoo10
cd /opt/odoo10
cp setup/odoo odoo-bin
touch odoo.conf

然后即可正常使用

 欧度智能: Odoo成功100%
Odoo专业开发实施,原广州尚鹏
  • Odoo项目100%海内外成功交付
  • Odoo官网下载第一,服务上千企业
  • Odoo官网销量第一的中国公司
  • 钉钉、企业微信认证服务商
  • 微软中国ChatGPT服务商,Ai中心
  • 百度千帆、阿里通义千问服务商
  • 十年专注Odoo,服务智能制造
  • Odoo中文应用商店,海量模块 
odoo10 安装python的依赖及坑error: command gcc failed with exit status 1
欧度智能, 店小二
2016年11月18日
2024年4月3日
6,336
评论:
0
标签
存档
登录 留下评论
Odoo环境下Ubuntu服务器性能优化–参数调整